Login portal connectivity issues
Incident Report for Vera Control, Ltd.
Resolved
Platform is fully operational.
Posted 9 months ago. Sep 04, 2017 - 10:59 PDT
Investigating
Our servers are experiencing high traffic load and you might not be able to login to portal page.
Please do no try to reset your password. The issues will be resolved servers side, without any need of intervention from client side.

Our apologies for any inconvenience this brief interruption in service may cause.

As always, should you have any questions, comments, or concerns, please email us at support@getvera.com.
Posted 9 months ago. Sep 04, 2017 - 06:49 PDT